Engage Platform Unavailable
      
Major incident
      
        Engage
    
    
      
2024-10-31 11:41 EDT
      
      · 1 minute
    
  Updates
          Resolved
        
        
October 31, 2024 · 11:32 EDT
        
      
      Full functionality has been restored to the Engage platform. Users can now access the platform and resume sending text and email communications as usual.
          Issue
        
        
October 31, 2024 · 10:50 EDT
        
      
  We are currently experiencing an issue affecting all users’ ability to sign into the Engage platform. Our teams, alongside vendor partners, are working urgently to resolve this and restore full functionality.
← Back
 Enumerate Status
            
Enumerate Status